

浏览全部资源
扫码关注微信
Online First:2021-06,
Published:15 June 2021
移动端阅览
Zheng HE, Feng LENG, Cuiling ZHANG. Operation mechanism for ensuring the stable migration of top-level domain name resolution hosting services with DNSSEC[J]. Chinese Journal of Network and Information Security, 2021, 7(3): 156-165.
Zheng HE, Feng LENG, Cuiling ZHANG. Operation mechanism for ensuring the stable migration of top-level domain name resolution hosting services with DNSSEC[J]. Chinese Journal of Network and Information Security, 2021, 7(3): 156-165. DOI: 10.11959/j.issn.2096-109x.2021059.
基于顶级域解析服务托管平台迁移部署实践,重点研究分析了在DNSSEC环境下,为避免发生域名系统安全扩展(DNSSEC,DNS security extension)信任链及解析服务中断、域名NS记录不一致等安全问题,如何在密钥轮转、DS 和 NS 记录变更、数据更新等环节中实现新旧服务托管商及互联网数字分配机构(IANA,internet assigned numbers authority)之间进行解析服务平台的迁移,并对平台迁移操作的关键点进行了详细分析,提出了在解析托管服务迁移过程中能够保证业务连续性的迁移机制。
Based on the migration and deployment practice of the top-level domain resolution service hosting platform
in order to avoid the occurrence of domain name system security extension (DNSSEC
DNS security ex-tension) trust chain and resolution service interruption
domain name NS record inconsistency and other security issues in the DNSSEC environment
research and analysis was focused on how to migrate the resolution service between the old and new service hosting platform and the internet assigned numbers authority (IANA) without breaking the integrity of the DNSSEC trust chain during the key rollover
DS and NS record changes
data update and other stages.To improve the availability of domain name system services
the key points of the platform migration operation were analyzed in detail
and the migration mechanism that can ensure business continuity during the migration process were proposed.
苑朋朋 , 王常青 . DNS安全威胁及应对措施研究 [J ] . 网络空间安全 , 2018 , 9 ( 5 ): 50 - 54 .
YUAN P P , WANG C Q . Research on DNS security threats and countermeasures , 2018 , 9 ( 5 ): 50 - 54 .
KOLKMAN O , MEKKING W , GIEBEN R . RFC 6781:DNSSEC operational PRactices [S ] . RFC IETF , 2012 .
EASTLAKE D . RFC 2065:domain name system security extensions [S ] . RFC IETF , 1997 .
EASTLAKE D . RFC 2535:domain name system security extensions [S ] . RFC IETF , 1999 .
AUSTEIN R , LARSON M . RFC 4033:DNS security introduction and requirements [S ] . RFC IETF , 2005 .
ARENDS R , AUSTEIN R , LARSON M , et al . RFC4034:resource records for the dns security extensions [S ] . RFC IETF , 2005 .
ARENDS R , AUSTEIN R , LARSON M , et al . RFC4035:protocol modifications for the dns security extensions [S ] . RFC IETF , 2005 .
LAURIE B , SISSON G , ARENDS R , et al . RFC 5155:DNS security(DNSSEC) hashed authenticated denial of existence [S ] . RFC IETF , 2003 .
Root DNSSEC update [EB ] .
TLD DNSSEC report [EB ] .
New gTLD program statistics [EB ] .
段海新 . DNSSEC原理、配置与部署 [J ] . 中国教育网络 , 2011 ,( 6 ): 29 - 31 .
DUAN H X . DNSSEC principle,configuration and deployment [J ] . China Education Network , 2011 ,( 6 ): 29 - 31 .
段海新 . DNSSEC原理、配置与部署(二) [J ] . 中国教育网络 , 2011 ,( 7 ): 34 - 35 .
DUAN H X . DNSSEC principle,configuration and deployment(2) [J ] . China Education Network , 2011 ,( 7 ): 34 - 35 .
高二辉 , 张跃冬 , 何峥 . DNSSEC 技术原理及应用研究 [J ] . 信息安全与技术 , 2013 ,( 1 ): 10 - 15 .
GAO E H , ZHANG Y D , HE Z . The principle and application research of DNSSEC [J ] . Information Security and Technology , 2013 ,( 1 ): 10 - 15 .
0
Views
219
下载量
0
CSCD
Publicity Resources
Related Articles
Related Author
Related Institution
京公网安备11010802024621