

浏览全部资源
扫码关注微信
1. 中国互联网络信息中心,北京 100190
2. 互联网域名管理技术国家工程实验室,北京 100190
Online First:2017-03,
Published:15 March 2017
移动端阅览
Zhi-wei YAN, Guang-gang GENG, Hong-tao LI, et al. Study on the development of the DNS root system[J]. Chinese Journal of Network and Information Security, 2017, 3(3): 1-12.
Zhi-wei YAN, Guang-gang GENG, Hong-tao LI, et al. Study on the development of the DNS root system[J]. Chinese Journal of Network and Information Security, 2017, 3(3): 1-12. DOI: 10.11959/j.issn.2096-109x.2017.00150.
以DNS根服务体系发展历史为切入点,阐述了根服务器及根区文件的管理模式,针对DNS根服务器管理模式面临的效率、可扩展性以及稳定性等方面的缺陷,从政策层面综述了国际社群对扩展 DNS 根服务器的相关讨论和结论,并基于若干开放性原则进一步从技术层面详细论述和分析了扩展 DNS 根服务体系的相关解决方案。
The development history of the DNS root system was described and the management of the DNS root service was explained in detail.Based on the shortcomings on efficiency
scalability and stability of the current DNS root server management model
the extension schemes from both policy and technology points of views were summarized and analyzed.
LEE T , HUFFAKER B , FOMENKOV M , et al . On the problem of optimization of DNS root servers' placement [C ] // Passive and Active Network Measurement Workshop(PAM) . 2003 .
HARDIE T . Distributing authoritative name servers via shared unicast addresses [S ] . IETF RFC3258 , 2002 .
PARTRIDGE C , MENDEZ T , MILLIKEN W . Host anycasting service [S ] . IETF RFC1546 , 1993 .
ICANN Board of Directors . Draft minutes of the special board meeting [R ] . 2009 .
ICANN Root Scaling Steering Group(RSSG) . Root scaling study terms of reference [R ] . 2009 .
ICANN . Report of the security and stability advisory committee on root scaling [R ] . 2010 .
ICANN . Scaling the root-report on the impact on the DNS root system of increasing the size and volatility of the root zone [R ] . 2009 .
ICANN . Description of the DNS root scaling model,TNO information and communication technology [R ] . 2009 .
ICANN Root Server System Advisory Committee(RSSAC) . Draft proposal,based on initial community feedback,of the principles and mechanisms and the process to develop a proposal to transition NTIA’s stewardship of the IANA functions [R ] . 2014 .
ICANN . Service expectations of root servers [R ] . 2013 .
ICANN . RSSAC recommendation on measurements of the root server system [R ] . 2014 .
[EB/OL ] . http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_ 7-2/dnssec.html http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_ 7-2/dnssec.html .
ICANN . Accommodating IP version 6 address resource records for the root of the domain name system [R ] . 2007 .
ICANN . Analysis of the DNS root and gTLD nameserver system:status and progress report [R ] . 2008 .
PERLMAN R . Interconnections [R ] . 1999 .
GARCIA-LUNA-ACEVES J J , . Loop-free routing using diffusing computations [C ] // IEEE/ACM Trans.on Networking . 1993 : 130 - 141 .
LABOVITZ C , AHUJA A . Delayed Internet routing convergence [C ] // IEEE/ACM Trans.on Networking . 2001 : 293 - 306 .
LABOVITZ C , . The impact of internet policy and topology on delayed routing convergence [C ] // IEEE Infocom . 2001 .
SARAT S , PAPPAS V , TERZIS A . On the use of anycast in DNS [C ] // IEEE ICCCN . 2006 .
中国互联网络信息中心 . 中国域名服务安全状况与态势分析报告 [R ] . 2014 .
China Internet Network Information Center . Chinese domain name service security situation and trend analysis report [R ] . 2014 .
中国互联网络信息中心 . 第35次中国互联网络发展状况统计报告 [R ] . 2015 .
China Internet Network Information Center . The 35th China Inter-net network development state statistic report [R ] . 2015 .
CARPENTER B . Architectural principles of the Internet [S ] . IETF RFC1958 , 1996 .
LIMONCELLI T A , HOGAN C J , CHALUP S R . The practice of system and network administration [R ] . 2007 .
DENNING P J . The locality principle [J ] . ACM Communication , 2005 , 48 ( 7 ): 19 - 24 .
Future Internet Architecture(FIArch)Group . Future Internet design principles [R ] . 2012 .
CLARK D , CHAPIN L , CERF V , et al . Towards the Future Internet Architecture [S ] . IETF RFC1287 , 1991 .
ABLEY J . Hierarchical anycast for global service distribution [R ] . ISC technical note 2003-1 , 2003 .
SAVAGE S , . The end-to-end effects of internet path selection [C ] // ACM Sigcomm . 1999 .
SPRING N , MAHAJAN R , ANDERSON T . Quantifying the causes of path inflation [C ] // ACM Sigcomm . 2003 .
VIXIE P . Extension mechanisms for DNS(EDNS0) [S ] . IETF RFC2671 . 1999 .
VIXIE P , KATO A , ABLEY J . DNS response size issues [R ] . 2014 .
ARENDS R . Protocol modifications for the DNS security extensions [S ] . IETF RFC4035 . 2005 .
BELLIS R . DNS transport over TCP-implementation requirements [S ] . IETF RFC5966 . 2010 .
DEERING S , HINDEN R . Internet protocol,version 6(IPv6)Specification [S ] . RFC2460 . 1998 .
[EB/OL ] . https://www.icann.org/resources/pages/rssac-caucus-201405-06-en https://www.icann.org/resources/pages/rssac-caucus-201405-06-en .
ICANN . Overview and history of the IANA functions [R ] . 2014 .
[EB/OL ] . http://tools.ietf.org/wg/dnsop http://tools.ietf.org/wg/dnsop .
KUMARI W , HOFFMAN P . Decreasing access time to root servers by running one on loopback [R ] . 2015 .
LEE X D , VIXIE P , YAN Z W . How to scale the DNS root sys-tem? [R ] . 2014 .
OHTA M . Distributing root name servers via shared unicast ad-dresses [R ] . 1999 .
SATO S , MATSUURA T , MORISHITA Y . BGP anycast node re-quirements for authoritative name servers [R ] . 2007 .
BUSH R , KARRENBERG D , KOSTERS M , et al . Root name server operational requirements [S ] . IETF RFC2870 , 2000 .
Identifying and characterizing anycast in the domain name system [R ] . USC/ISI Technical Report . 2011 .
WANG W , YAN Z W . A survey of the DNS cache service in China [J ] . Modern Preventive Medicine , 2015 .
COX R , MUTHITACHAROEN A , MORRIS R T . Serving DNS using a peer-to-peer lookup service [C ] // The International Workshop on Peer-to-Peer Systems . 2002 .
MUELLER M L , . Competing DNS roots:creative destruction or just plain destruction [C ] // Research Conference on Communication,Information . 2001 .
IAB . IAB technical comment on the unique DNS root [S ] . IETF RFC2826 , 2000 .
0
Views
5671
下载量
0
CSCD
Publicity Resources
Related Articles
Related Author
Related Institution
京公网安备11010802024621